Skylook Operating Environment     

Skylook works on these operating systems:

  • Windows 7 (32 bit & 64 bit versions [NOTE: Office 32 bit, the default option, must be installed, not Office 64 bit])
  • Windows Vista
  • Windows XP
  • Windows 2000

IMPORTANT: You must use a Windows account with Administrator access in order to install Skylook.

Skylook works with these versions of Skype:

  • V1.x
  • V2.x
  • V3.x
  • V4.0
  • V4.1
  • V4.2
  • V5.0

Skylook works with these versions of Outlook:

  • Outlook 2000
  • Outlook XP/2002
  • Outlook 2003
  • Outlook 2007
  • Outlook 2010 (NOTE: 64 bit Windows supported, but only if 32 bit Office is installed [this is the default installation])

Skylook works with this hardware:

  • Windows compatible PC
  • Pentium 4 or better
  • 2.0 GHz or faster
  • Memory: 1 GB or more
  • Any Skype-compatible sound card or USB phone

Important note regarding outgoing network connections made by Skylook